Page 1 of 5 12345 LastLast
Results 1 to 10 of 43
Like Tree6Likes

Thread: 2013 Camaro 2SS/RS... Mylink removed, I7 Mobile Project

  1. #1
    Maximum Bitrate rray's Avatar
    Join Date
    Apr 2012
    Location
    SF Bay Area
    Posts
    618

    2013 Camaro 2SS/RS... Mylink removed, I7 Mobile Project

    As soon as I finished my 2012 Camaro 1LT, I found a closeout deal on a 2013 Camaro 2SS/RS that I could not beat.
    After suffering without a carpc all summer, I finally got rid of that horrible Mylink Navigation. This weekend I put the replacement in, an I7 Mobile based CarPC, this time in a Voom2 PC Case.

    Here is my new pimp mobile... I gotta have my midlife crisis don't I? Yes it looks like the old one but has more bells and whistles, and the old car had 7600 miles on it, time for a new one.


    I did a little engine compartment dressup, added a catch can, stiffened up the supension, etc:


    And on the inside, I had this Mylink Navcom with Boston Acoustic Premiun Sound that was exceptionally crappy. I'm talking glitchy operation, 1 out of 10 small thumb drives works, every power up it defaults to FM radio, major hiss from the tweeters, basicly, a couple thousand dollars worth of pure crap, so out it went!


    First I removed the Mylink screen and Nav Radio. That radio even had a CD slot hidden behind the screen with no way to access it. I had to cut some plastic away so all my electronics and the 8" screen would fit:

  2. #2
    Maximum Bitrate rray's Avatar
    Join Date
    Apr 2012
    Location
    SF Bay Area
    Posts
    618
    Next I made a video cable to tap into the oem backup camera, after getting and info and pin numbers from 2SSRS@Gen5diy, StealthZL1, and Robdollar77 from the Camaro5 forum:


    I was able to use a 90 degree Dupont Pin Header, as the pin spacing was perfect at 2.54mm, and I ty-wrapped it onto the connector so the cable would not come unplugged:


    I built up a CarPC using mostly high temperature industrial components. An industrial socket G2 motherboard, Mobile I7 35W processor, 85C rated low profile DDR3, and I used a Hifidiy Saber USB DAC to output an extremely transparent audio signal. The power supply is a 160W intellegent DC-DC converter that uses a combination of ignition switch position, and timers to start and stop the PC, so I don't ever have to power down the PC. I just drive, and it runs automatically, and powers down automatically when I pull out the key:


    I routed the case cables with airflow in mind:

  3. #3
    Maximum Bitrate rray's Avatar
    Join Date
    Apr 2012
    Location
    SF Bay Area
    Posts
    618
    And after slapping the case together, installed a USB Bluetooth Dongle, and a Dual Band N WIFI Dongle:


    There's lots of ports for expansion, as I add more devices down the road:


    I modified the Metra kit to fit an 8" HDMI touchscreen, HDMI and Composite TFT driver board with auto video switching so I could switch from PC to Backup Camera whe I put the tranny in reverse, a Joycon programmable steering wheel button interface, and an intellegent 80W DC-DC converter to provide computer grade power for the screen and electronics:


    I mounted the PC, Amps, Cap, and Sound Processor behind the seat and on the backside of the SUB box. Everything here is powered from a second Stinger Battery when the engine is off, and isolation opens up after the engine is started:


    I have both a 1 Farad cap and a backup battery. The cap is just to make extra sure I don't have any power dips that could cause the PC to reset. Here is the batteries and isolation solenoid:


    Here is the 8" touchscreen mounted in the metra dash kit:



    Now I have to figure out where I want to mount the Ram Tough USB Hub so I can plug stuff in at the console. Thinking...
    Dave One and protias like this.

  4. #4
    FLAC PhilG's Avatar
    Join Date
    Mar 2009
    Location
    Ontario, Canada
    Posts
    927
    Nice job rray, the screen fit well and just enough space to add all of the "boxes" in the rear without crowding them. Awesome. You are going to integrate that GPS antenna, right?

    I'm confused though, the 3rd pic down from yesterday shows those round "tire looking" HVAC controls and your last pic here has 2 rows of rectangle buttons. Did that change happen when you replaced the centre dash piece from a car without the My link or are all of those buttons part of the Metra kit or?
    My 2007 Ford F350 Work Log located HERE

  5. #5
    Maximum Bitrate rray's Avatar
    Join Date
    Apr 2012
    Location
    SF Bay Area
    Posts
    618
    Yes, the round controls are the stock air conditioning controls with the stock 7" screen, where the buttons are the new air conditioning controls on the 8" screen panel.

    I want to put the GPS on the front dash, but need to get more USB ports up front.

    So it lasted 1 day... Monday everything worked great.

    Now the bad news... This morning, the PC hung at the BIOS screen with a B4 post code. I unplugged the power to the computer and started off to work. To make matters worse, once I got on the freeway the car started doing all kinds of glitches. The Speedo and Tach dropped to 0 on the freeway, then the driver info console started spewing out errors, Flat Tire, Check Engine, etc. Then the disconnected stock center channel speaker started buzzing, and dash lights started flickering. I made it to work but am afraid to drive home.

    Looking for Metric tools to disconnect all the dash stuff before I drive home.

    I took a course on troubleshooting once. They taught that there is only 1 assignable cause to a problem, although there can be many symptoms. Looks like I have to build an Ishikawa Fishbone Diagram and start pulling off the bones, but I suspect it's something on the materials leg, because it did work great Sunday afternoon and all day Monday.
    Last edited by rray; 10-22-2013 at 09:19 AM.

  6. #6
    Variable Bitrate camo.b's Avatar
    Join Date
    Nov 2011
    Posts
    280
    Bad earth? That's a huge list of problems....

  7. #7
    FLAC PhilG's Avatar
    Join Date
    Mar 2009
    Location
    Ontario, Canada
    Posts
    927
    I'm sorry to hear things are getting sideways but it will likely be fine once you unplug the culprit. I'm going to go out on a limb and guess that you used an interface device from Scosche, Metra, etc to restore dash functionality and it has failed. If that's the case, unplugging it may fix a few things but either replacing it or plugging the factory Nav unit back in will likely completely solve it. GM ties a ton of stuff through their factory head units Chrysler too for that matter. I had a Scosche adapter go bad on a Chrysler 300 NAV install I did for a guy and he had signal lights randomly going, headlights, seat belt warnings, all acting up. I also had a Scosche DOA on a Sunfire install I did... Since then I have stayed away from Scosche...probably wise.

    If it's any consolation, I really like the look of the buttons better for the HVAC system over the "tires".
    My 2007 Ford F350 Work Log located HERE

  8. #8
    Maximum Bitrate rray's Avatar
    Join Date
    Apr 2012
    Location
    SF Bay Area
    Posts
    618
    I just disconnected everything on my coffee break. I also suspect the Metra air conditioning controller, but it could be the Metra OnStar interface too. I have a spare metra air conditioning controller at home so I will try that tonight.

    -Robert

  9. #9
    FLAC PhilG's Avatar
    Join Date
    Mar 2009
    Location
    Ontario, Canada
    Posts
    927
    Without the OEM head unit plugged back in, I suspect you will still have problems but hopefully less to get you home. I would suggest when you get home, plug the factory unit back in first and see if all is good, that will give you a starting point. Keep us posted.
    My 2007 Ford F350 Work Log located HERE

  10. #10
    MySQL Error scott_fx's Avatar
    Join Date
    Dec 2004
    Location
    Los Angeles Ca
    Posts
    3,983
    quick question. did you use an aftermaket installation surround? or did you hack up the oem bezel to get your screen in there? it looks great btw
    New System in progress:
    M10k
    Phaze TD1500 ~> Dynaudio MD130
    Phaze TD1500 ~> Seas g18rnx/p
    Zapco Ref 500.1 ~ 12" tc-9
    Behringer DCX2496 ~ Envision Electronics psu
    Transflective Xenarc

    My Car Pc Install
    My Boat Pc worklog

Page 1 of 5 12345 LastLast

Similar Threads

  1. 2012 Camaro In Dash PC Project
    By rray in forum Worklogs
    Replies: 103
    Last Post: 10-01-2013, 09:53 PM
  2. 1967 camaro Project
    By sikryd in forum Worklogs
    Replies: 0
    Last Post: 08-15-2010, 11:38 PM
  3. Project Media-Z - 99 Camaro Z28
    By kiztope in forum Show off your project
    Replies: 23
    Last Post: 08-18-2006, 10:20 AM
  4. Project 'Uber-Hack Camaro' first boot in car!!
    By stealthy-one in forum Show off your project
    Replies: 15
    Last Post: 05-21-2006, 01:01 AM
  5. Project 'Uber-Hack Camaro' first boot in car.
    By stealthy-one in forum Worklogs
    Replies: 2
    Last Post: 05-18-2006, 06:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •