Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 41

Thread: 2004 Nissan Titan LE install

  1. #21
    Newbie
    Join Date
    Jul 2005
    Posts
    28
    Hey whats up,

    I just bought a Nissan Titan KC LE and I was planning on doing a simlar set up like yours with the Lilliput 7'' 639GL. I was wondering 2 things:

    1. How did you mount the LCD to the bezel, did you screw it in, hot glue it, tape it down, ect..? Did you have to dremel either of the bezels (the lcd's or the dash bezel)

    2. How did you hook up the audio from the computer to the factory rockford fosgate system? I know there is the front AUX input, but running that would look really ugly in the front. Is there anything in the back that you can just plug RCAs or a 1/8'' to? for example the SAT function.


    Any info or tips on difficulties you encountered would be much appreciated.

  2. #22
    Newbie
    Join Date
    Jan 2006
    Posts
    2
    I mounted the 7" lilliput in the bezel with hot glue and 2-part epoxy. I thought the hot glue might get hot in the truck and re-melt. I didn't dremel anything..it fit perfectly.

    I did take the lilliput apart and remove the remote control sensor and extend the wire and mount it behind the little vent on the lower left of the nissan bezel near the 4x4 switch..now the lcd remote works...otherwise the remote sensor would be blocked by the housing above the radio.

    2. As for hooking into the factory radio. I don't have the RF radio...I have the regular single cd player that doesn't have a input. I used a "rf modulator" that connects at the antenna jack on the back of the radio and I set it to 87.7 mHZ. I tune to that station and it plays the computer audio through the stereo system. Sound quality is lost through the radio because the FM system does not handle the low and high frequiences.....but it sounds good.

    Check the forums..many guys have cut the input wire and wired into it from the back side to hide the connection and it has worked fine.

    Be sure to run your power and speaker wires away from each other...I did and I still get a little hum in the radio...I will try a ground loop isolator.

    When you are finished, you will see that the radio bezel doesn't fit perfectly on the new nav bezel...I had to cut about 1" off the top of my radio face plate....just take your time...I clamped a metal ruler to the plastic and used a really sharp razor blade knife to cut over and over until it snapped....a dremel would have left a melted edge.

  3. #23
    Newbie
    Join Date
    Jul 2005
    Posts
    28
    Thanks a lot for your help. I will do some more research on the wiring before I start to invest in this system. But yeah thanks again!

  4. #24
    tk3
    tk3 is offline
    Newbie
    Join Date
    Jul 2006
    Posts
    2
    Quote Originally Posted by DeadlyAP1
    Yeah, on second thought, it's probably closer to 10 but not over I wouldnt say. I'll time it sooner or later. I haven't timed it from cold boot, but it's a while. Plus you have to go through the Touchkit calibration screen for the lilliput EVERY time you cold boot. F that.
    You don't have to do this every time. Just go into touchkit and turn off the setting that makes calibration popup on startup.

  5. #25
    My man uses Levitra. Peoples's Avatar
    Join Date
    Dec 2004
    Location
    Maryland
    Posts
    2,024
    i have that same soldering iron.....its friggen awesome
    PC Components:
    Lilliput; XPC/FLEX mobo; 1.7 ghz P4 Mobile;512 DDR; 160 gb HDD; opus 150; slot usb dvd-rw
    My work log

  6. #26
    Newbie
    Join Date
    Sep 2006
    Location
    San Diego
    Posts
    2
    This is great. I have a 2004 Titan SE and I plan on doing a similar project. I have a few questions as to where you found the best prices, and purchased, your ampie case, NAV Bezel and LCD Screen. I need to piece it out and get going! Thanks for the direction!!!

  7. #27
    Constant Bitrate DeadlyAP1's Avatar
    Join Date
    Aug 2005
    Location
    MA
    Posts
    207
    Quote Originally Posted by camdog View Post
    This is great. I have a 2004 Titan SE and I plan on doing a similar project. I have a few questions as to where you found the best prices, and purchased, your ampie case, NAV Bezel and LCD Screen. I need to piece it out and get going! Thanks for the direction!!!

    I found that the best prices for the ampie case, M1-ATX and lilitput were on ebay. Just buy from a reputable seller. Go to courtesy nissan for the bezel. the part numbers and their link can be found on titantalk.com

    I recently re-did the entire system by getting rid of the ampie and mounting everything in the glovebox. As you know because the truck is so damned big, its tough to reach the glove box so I never used it anyway. With the center console and the overhead storage I fifgured the glovebox was the best place. Now I dont have 10000 wires under my carpet and its easy to make equipment changes quickly. Good luck.

  8. #28
    Newbie
    Join Date
    Sep 2006
    Location
    San Diego
    Posts
    2
    That's awesome. If you have any pictures of the new glove box mount, I'd love to see them. You have my gmail address so if you have time, contact me there with a few pics. I'll post on here as soon as I kick off my build. Thanks

  9. #29
    Newbie
    Join Date
    Jan 2007
    Posts
    9
    Quote Originally Posted by DeadlyAP1 View Post
    I found that the best prices for the ampie case, M1-ATX and lilitput were on ebay. Just buy from a reputable seller. Go to courtesy nissan for the bezel. the part numbers and their link can be found on titantalk.com

    I recently re-did the entire system by getting rid of the ampie and mounting everything in the glovebox. As you know because the truck is so damned big, its tough to reach the glove box so I never used it anyway. With the center console and the overhead storage I fifgured the glovebox was the best place. Now I dont have 10000 wires under my carpet and its easy to make equipment changes quickly. Good luck.
    Would you please post a pic of how you mounted it in the glove box?

  10. #30
    Newbie KingFlip's Avatar
    Join Date
    Mar 2007
    Posts
    1
    Hey Looks Bithcin'... Did You Have A Problem With The Center Being Flush With The Finisher? Just Tried The Same But It Wasnt Completely Flush.....have To Grab My Dremel

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Freak show - 22 year old Nissan install
    By Yuriy in forum Show off your project
    Replies: 28
    Last Post: 09-18-2007, 12:09 PM
  2. 1993 Nissan 240sx install
    By eatyummypuppies in forum Show off your project
    Replies: 15
    Last Post: 07-14-2006, 04:06 PM
  3. 2004 Nissan Frontier - GPS/MP3
    By Troy McClure in forum Show off your project
    Replies: 8
    Last Post: 05-19-2006, 04:17 PM
  4. Nissan 200SX install progress
    By M pro in forum Show off your project
    Replies: 35
    Last Post: 05-18-2005, 11:47 AM
  5. 04 Titan Install
    By Troy McClure in forum Show off your project
    Replies: 11
    Last Post: 01-27-2005, 03:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •